Lompat ke konten Lompat ke sidebar Lompat ke footer

Konfigurasi Routing EIGRP pada Cisco

Hello World; Malam Fans, Please Say Hello Haters ;*
Selamat Sabtu Malam awkwkkaw, btw kali ini Nue bakal Share Apa itu Routing EIGRP & Konfigurasi Routing EIGRP pada Router Cisco .
btw sebelumnya artikel pembahasan dan tutorial ini sudah pernah saya buat dengan Penjelasan memakai Contoh Studi Kasus EIGRP bisa di cek di: Sokin


Intro: Enhanced Interior Gateway Routing Protocol atau disingkat EIGRP adalah salah satu routing protocol yang digunakan untuk menghubungkan jaringan antar router secara dinamik. EIGRP merupakan protokol routing yang hanya dapat digunakan pada router- router cisco dan termasuk ke dalam distance vector routing protocol.
Salah satu kelebihan dari EIGRP adalah adanya feasible successor atau jalur backup yang akan menggantikan jalur utama apabila terjadi kegagalan link (down) pada jalur utama tersebut. Beberapa karakteristik dari eigrp antara lain :

- Menggunakan algoritma DUAL
- Memiliki hop count sebanyak 224
- Dapat melakukan convergence secara cepat
- Mampu menonaktifkan auto-summary route
- Menggunakan composite metric

Untuk melakukan konfigurasi routing eigrp, setidaknya terdapat dua langkah yang harus dilakukan, yakni mengaktifkan routing eigrp dan mengadvertise network yang terhubung dengan router. Untuk mengaktifkan routing eigrp menggunakan comamnd :

router eigrp [ASN]

ASN (Autonomous System Number) merupakan sebuah identifier yang digunakan router-router eigrp untuk mengenali router eigrp yang lainnya. Router eigrp hanya dapat berkomunikasi dengan router eigrp lain yang berada dalam satu ASN yang sama. Apabila router ingin berkomunikasi dengan router lain yang terletak di ASN yang berbeda, maka harus dilakukan redistribute. Untuk saat ini kita belum akan membahas tentang redistribute ini.

Sedangkan untuk mendaftarkan (advertise) network menggunakan perintah :

network [network_address]

yang dimaksud network address pada perintah di atas adalah network yang terhubung secara langsung dengan router.

Terdapat opsi lain untuk melakukan advertise network yakni dengan menambahkan wildcard mask dibelakang network address, seperti berikut :

network [network_address] [wildcard mask]

wildcard mask di atas berfungsi untuk menentukan network tertentu (spesifik) yang harus diadvertise.

Kita juga bisa menggunakan perintah opsional namun sangat disarankan yaitu no auto-summary . Perintah ini berguna agar network address tidak disummarisasi (auto summarize). Untuk beberapa kasus, perintah ini sangat penting karena jika tidak menggunakan perintah ini, bisa-bisa routing akan menjadi kacau. (Silahkan baca link tentang auto summarize yang sudahgua tautkan) .

Contoh Konfigurasi Routing EIGRP
Topologi di atas merupakan contoh atau ilustrasi dari tiga buah router yang akan menggunakan routing eigrp. Jika masih bingung dengan ip yang digunakan oleh router dan PC di atas, silahkan lihat tabel di bawah ini :
Dan berikut adalah konfigurasi dari masing-masing router di atas,

Konfigurasi R1 :

Router>enable
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#hostname R1
R1(config)#int fa0/0
R1(config-if)#ip add 192.168.1.254 255.255.255.0
R1(config-if)#no shut


R1(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R1(config-if)#int s2/0
R1(config-if)#ip add 100.100.100.1 255.255.255.252
R1(config-if)#no shut


%LINK-5-CHANGED: Interface Serial2/0, changed state to down
R1(config-if)#int s3/0
R1(config-if)#ip add 100.100.100.5 255.255.255.252
R1(config-if)#no shut


%LINK-5-CHANGED: Interface Serial3/0, changed state to down
R1(config-if)#exit
R1(config)#router eigrp 1
R1(config-router)#network 192.168.1.0 0.0.0.255
R1(config-router)#network 100.100.100.0 0.0.0.3
R1(config-router)#network 100.100.100.4 0.0.0.3
R1(config-router)#no auto-summary
R1(config-router)#exit
R1(config)#do write
Building configuration...
[OK]
R1(config)#


Konfigurasi R2 :

Router>ena
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#host R2
R2(config)#int fa0/0
R2(config-if)#ip add 192.168.2.254 255.255.255.0
R2(config-if)#no shut


R2(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R2(config-if)#int s2/0
R2(config-if)#ip add 100.100.100.6 255.255.255.252
R2(config-if)#no shut


R2(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up



%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

R2(config-if)#int s3/0
R2(config-if)#ip add 100.100.100.9 255.255.255.252
R2(config-if)#no shut


%LINK-5-CHANGED: Interface Serial3/0, changed state to down
R2(config-if)#
R2(config-if)#router eigrp 1
R2(config-router)#network 192.168.2.0 0.0.0.255
R2(config-router)#network 100.100.100.4 0.0.0.3
R2(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 100.100.100.5 (Serial2/0) is up: new adjacency


R2(config-router)#network 100.100.100.8 0.0.0.3
R2(config-router)#no auto-summary
R2(config-router)#exit
R2(config)#do write
Building configuration...
[OK]
R2(config)#


Konfigurasi R3 :

Router>ena
Router#conf t
Enter configuration commands, one per line.  End with CNTL/Z.
Router(config)#host R3
R3(config)#int fa0/0
R3(config-if)#ip add 192.168.3.254 255.255.255.0
R3(config-if)#no shut


R3(config-if)#
%LINK-5-CHANGED: Interface FastEthernet0/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/0, changed state to up

R3(config-if)#int s2/0
R3(config-if)#ip add 100.100.100.2 255.255.255.252
R3(config-if)#no shut


R3(config-if)#
%LINK-5-CHANGED: Interface Serial2/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial2/0, changed state to up

R3(config-if)#int s3/0
R3(config-if)#ip add 100.100.100.10 255.255.255.252
R3(config-if)#no shut


R3(config-if)#
%LINK-5-CHANGED: Interface Serial3/0, changed state to up


%LINEPROTO-5-UPDOWN: Line protocol on Interface Serial3/0, changed state to up

R3(config-if)#router eigrp 1
R3(config-router)#net 192.168.3.0 0.0.0.255
R3(config-router)#net 100.100.100.0 0.0.0.3
R3(config-router)#
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 100.100.100.1 (Serial2/0) is up: new adjacency


R3(config-router)#net 100.100.100.8 0.0.0.3
R3(config-router)#no auto-summary
%DUAL-5-NBRCHANGE: IP-EIGRP 1: Neighbor 100.100.100.9 (Serial3/0) is up: new adjacency


R3(config-router)#exit
R3(config)#do write
Building configuration...
[OK]
R3(config)#


Konfigurasi PC :

Setelah konfigurasi semua perangkat telah selesai, selanjutnya cek apakah masing-masing network telah terkoneksi atau belum dengan melakukan ping dari satu PC ke PC lain. Pastikan sudah terkoneksi ya, jika belum, berarti masih ada konfigurasi yang keliru.

Kita juga dapat melakukan verifikasi menggunakan perintah-perintah di bawah ini :

show ip route
show ip route eigrp


Contoh verifikasi routing pada R1 :

R1#show ip route 
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP 
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR
       P - periodic downloaded static route

Gateway of last resort is not set

     100.0.0.0/30 is subnetted, 3 subnets
C 100.100.100.0 is directly connected, Serial2/0
C 100.100.100.4 is directly connected, Serial3/0
D 100.100.100.8 [90/21024000] via 100.100.100.6, 00:00:37, Serial3/0
                [90/21024000] via 100.100.100.2, 00:00:08, Serial2/0
C 192.168.1.0/24 is directly connected, FastEthernet0/0
D 192.168.2.0/24 [90/20514560] via 100.100.100.6, 00:00:37, Serial3/0
D 192.168.3.0/24 [90/20514560] via 100.100.100.2, 00:00:08, Serial2/0

R1#show ip route eigrp
     100.0.0.0/30 is subnetted, 3 subnets
D       100.100.100.8 [90/21024000] via 100.100.100.6, 00:00:50, Serial3/0
                      [90/21024000] via 100.100.100.2, 00:00:21, Serial2/0
D 192.168.2.0/24 [90/20514560] via 100.100.100.6, 00:00:50, Serial3/0
D 192.168.3.0/24 [90/20514560] via 100.100.100.2, 00:00:21, Serial2/0

Demikianlah pembahasan mengenai konfigurasi routing eigrp pada router cisco. Tidak banyak penjelasan yang dapat gua berikan karena gua sendiri masih belajar. Namun gua harap sedikit konfigurasi di atas dapat memberikan pemahaman mengenai cara mengkonfigurasi eigrp.

Mampir juga ke artikel di Blog ini yg setema dengan tutorial kali ini > Label Cisco Packet Tracer

owh iya, Bila ada Link atau gambar pada Artikel Blog ini ada yang rusak/Mati, harap lapor disini

Stay Cool and Keep ./Crotz , gaes <(")
bila ada kesalahan mohon di maafkan dan dibenarkan di kolom komentar kak.
bila ada kritik, dan pertanyaan langsung aja kak ke wall fanspage kami: TKJ CYBER ART
Nue cuma niat untuk Share Tutorial, yg bertujuan utk membantu para pemula kek Nue :')
Sekian dan semoga bermanfaat .. terimakasih
 

Thanks to [Refrensi]:
ilmu Komputer

./Nuenomaru
tak perlu Sedarah untuk Bisa menjadi Saudara






Visit and follow :

FP         : TKJ Cyber Art

G+         : TKJ Cyber Art
youtube : TKJ Cyber Art
BBM      : C0018D1A2
Line       : http://line.me/ti/p/%40hjl8740i

Posting Komentar untuk " Konfigurasi Routing EIGRP pada Cisco"